Seat Arona Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there
I've had my Arona for a week, and several times the warning triangle has flagged up that the Front Assist is impaired. The manual explains that various things can affect the radar, including dirt on the panel on the front of the vehicle. I have tried cleaning the panel immediately prior to setting off, and the warning light still comes on - not every time, but it has happened several times in a week. It seems to go off after half a mile or so. Slightly unnerving! I spoke to someone in the servicing department of the Seat dealer from whom I bought the car, and he didn't seem unduly worried. Has anyone else had this problem?
 

·
Registered
Joined
·
299 Posts
Not had a problem but when I had my tiguan other people on that forum had this issue and either had the radar or the cover replaced under warranty. Heavy rain and spray can affect them as does a build up of dirt. I'd go back and get them to carry out diagnostics to check for any error codes, it is at the end of the day a safety device that you've paid for.
 

·
Registered
Joined
·
156 Posts
Are you still having this problem? I thought mine wasn't working so I set it to the most sensitive setting and it started picking up
road signs on bends, so I quickly reset it back to the medium setting (which is recommended) now all seems ok.
 

·
Registered
Joined
·
23 Posts
If you spoke to someone in the service department, and he didn't seem to worried, but it still kept flashing. you have 3 years warranty,
TAKE IT BACK. IT'S A NEW CAR How do you know the guy who gave you this information in the first place, was qualified? Just because he stands at the front desk, doesn't make him an expert.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top