Seat Arona Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 · (Edited)
Just wondered if anyone else has had this particular problem. I have a 2109 Arona FR and I normally have the MPG "from start" setting displayed on the centre dashboard info panel. This always worked perfectly well and gave me MPG info for each trip I did. Last week however the figures just started going crazy, changing every second and ranging from low single figures to as much as 300mpg - all in the space of a hundred yards or so! Occasionally three dashes ( - - - ) would also appear. The "long term" MPG setting seems OK and is showing what I would expect. I also checked the options on the infotainment screen and they seem reasonable also. The only thing I havn't done yet is gone for a drive with the MPG screen on the infotainment screen selected. I will try that later today as an experiment. One thing, which may be irrelevant, is that when the display was working fine it had the words "Since Start" below the figures but since this problem cropped up that text has disappeared.

Update I went out for a five mile drive with the both the infotainment screen set to MPG 'Since Start' and the same on the dashboard centre panel. The infotainment version worked perfectly but the dashboard panel was going mental again.

I tried to video the figures going crazy but the camera wouldn't focus properly so I have attached a few stills instead.

Speedometer Odometer Trip computer Tachometer Car
Wheel Tire Car Automotive lighting Automotive design
Vehicle Wheel Tire Car Automotive design
Tire Wheel Car Automotive tire Automotive design
 

·
Registered
Joined
·
182 Posts
That mpg reading seems to be your actual mpg at any one time. I would play with the settings a bit more. It may be just that and no fault.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
That mpg reading seems to be your actual mpg at any one time. I would play with the settings a bit more. It may be just that and no fault.
Not so sure about that mate. 235 mpg??? Thing is the display never used to go crazy like that on a single trip.
 

·
Registered
Joined
·
558 Posts
The first image is consumption, it updates every couple of seconds
From memory this goes upto 300mpg, and you get these high numbers when coasting or going downhill as using negligible fuel, at the other end of the scale if you floor the accelerator goes down to about 8mpg
I can’t remember as I never display it (not liking the numbers keeping changing) instead I prefer the digital miles per hour to be displayed.

The other screen shots are showing averages (the circle with sloping bar is mathematical symbol for average)

You can toggle your central display (small display between the speedo and rev dial) between current consumption mpg, and average, (and other things) using right thumbwheel. When you are on the average, you can push down the thumbwheel, then scroll whilst holding down, it will toggle since start, since refuel, long term options. From memory long term resets at 2000 miles.
 
  • Like
Reactions: shalebing

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
#Snowdaddy - Many thanks for your reply and apologies for taking so long to respond but I just havn't been using the car much of late.

After much faffing around I have managed to get the Consumption - Since Start back on the centre display and this is the one I used previously. It was a very hit and miss affair though as most of the time when holding down the thumbwheel and scrolling the only options I was getting were "Since refuel", "Range" and the long term option. "Since Start" just did not appear as an option so after many attempts I just gave up. I was out in the car this morning and decided to have another go and this time "Since Start" did appear but as soon as I let go of the scroll wheel it jumped to another option so I am assuming the scroll wheel isn't working as well as it should. After about five more attempts it now seems to have saved the "Since Start" option but time will tell if it retains it.
 

·
Registered
Joined
·
25 Posts
When showing the fuel consumption on the centre of the dash - pressing the scroll button on the right of the SW toggles between - Since Start - Since Refuelling - Long Term.

As suggested above - I think its just what you have selected.... rather than an issue.... Showing Instantaneous shows figures that jump around from 10 to 200... depending on where the accelerator is and for how long its been there..
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
When showing the fuel consumption on the centre of the dash - pressing the scroll button on the right of the SW toggles between - Since Start - Since Refuelling - Long Term.

As suggested above - I think its just what you have selected.... rather than an issue.... Showing Instantaneous shows figures that jump around from 10 to 200... depending on where the accelerator is and for how long its been there..
Yes I got there eventually although when I first pressed the scroll wheel I was only getting the options Since Refuelling, Range and Long Term and it took a number of attempts to even see Since Start as an option. I think there may be a dodgy connection in my scroll wheel.
 
1 - 7 of 7 Posts
Top